Did it work?

OK, peeps, I sent in a request for help through Jetpack support, telling them that I was having issues with the Facebook Publicize. This was part of their response, telling me what the problem is, and what to do to fix it.

“In your case, Facebook is not accepting your post for publication due to the open graph errors that you mentioned on your latest blog post. These are happening because you have the All-In-One SEO plugin installed, but it isn’t setup for adding social tags.

Since Facebook doesn’t like duplicate Open Graph tags either, Jetpack automatically disables our Open Graph tags to avoid any conflict when a plugin, like All-in-One is installed. But since we aren’t providing the tags nor is All-In-One, Facebook isn’t happy.

You can resolve this by either setting up All-In-One to insert Open Graph tags or you can install this plugin to reactivate Jetpack’s: https://wordpress.org/plugins/always-use-jetpack-open-graph/

Once either of those are done, the tags should return to your site and your site should publicize to Facebook as expected, based on the debugging information on our end.”

 

I looked at the All-in-One plug-in settings to see if I could modify it to add social tags, but I couldn’t find anywhere that I could do that.  I’m feeling pretty stupid at this point! So, that “All-in-One” plug-in that has been so highly recommended by so many people may be the culprit!

 

I have installed the “Always Use Jetpack Open Graph” plug-in that the Jetpack support recommended, and activated it. I am HOPING that will take care of the issue! Once I hit “Publish” I will go to Facebook and see if it appears or not. I hope it did! Wish me luck! If it works, I’ll add a “YAY it worked” comment below the appearing post!